Error Enabling HTTPS on Meridian’s web server (IIS)
After allowing the Meridian web access, users and even IT staff may be unable to access the web server to open PowerWeb when using HTTPS protocol. This means that PowerWeb is only accessible via HTTP, and the following error message is shown:
BlueCielo Web Access Server Error
The BlueCielo Web Access server failed to generate the page.
Could not create XML DOM componente or XSL process style sheets.
Please report this to the administrator of this web site.
On the Web Access server please check that MS-XML is properly installed.
Register msxml6.dll in the SYSTEM32 folder using regsvr32.exe
Cause
This issue is caused by SSL certificate misconfiguration.
Solution
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Ensure that you have configured the SSL certificate in Meridian’s IIS server for the default web site.
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Check if there is any problem with the SSL certificate configuration and fix it on Meridian’s IIS server.
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If the PowerWeb is configured with basic authentication mode and the problem persists, try to set to use Windows authentication instead.
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Create the necessary bindings (http and https for the proper machine name) under the default web site in Meridian’s IIS server.
The binding should be set to the certificate that is being used.
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If the problem is still occurring, try to access the PowerWeb site using the recovery URL to see the outcome. In most cases with issues relating to accessing PowerWeb, this solves the problem.
Recovery URL — https://Servername/Meridian/?recover